ANN: BuckleScript 5.1.0 and 6.1.0 ready for testing


Hi all,
We made a new release of bs-platform, feedback is very much appreciated!


Just tried to install 5.1.0 on windows. It fails with the following error.

734 error code ELIFECYCLE
735 error errno 1
736 error bs-platform@5.1.0 postinstall: node scripts/install.js
736 error Exit status 1
737 error Failed at the bs-platform@5.1.0 postinstall script.
737 error This is probably not a problem with npm. There is likely additional logging output above.
738 verbose exit [ 1, true ]


Additionally I have noticed that bs make-world -w is significantly slow in window compared to linux. In linux the compilation are in few hundred milliseconds. However, in windows they are more like 8000 milliseconds.


How is the speed of bsb -w (without -make-world)?


To clarify: it’s native Windows, not WSL?


Yes. Native Windows


Hi, I got a bit lost, you said you failed to install on windows, but reported that it’s slow.
In general, windows are expected to be slow, but it should be comparable instead of that gap.
To help diagnose the installation issues,
npm does not provide meaningful stacktrace, can you try this

npm install --ignore-scripts bs-platform@5.1.0
cd node_modules/bs-platform && node ./scripts/install.js


Hi Bob, the slowness is with the older version pre 5.1.0 and 6.1.0. I wanted to see if 5.1.0 or 6.1.0 fixed the slowness issue. However I couldn’t even install that version. 5.0.6 installs okay.


Just tried

npm install --ignore-scripts bs-platform@5.1.0
cd node_modules/bs-platform && node ./scripts/install.js

Install works however,

cd node_modules/bs-platform && node ./scripts/install.js

fails with the following,

ninja binary is copied from pre-distribution
child_process.js:637 bsc.win32 bsc.exe 1>nul
throw err;

Error: Command failed: C:\Users\reasonreact-todo\node_modules\bs-platform\lib\ninja.exe -f
at checkExecSyncError (child_process.js:616:11)
at Object.execFileSync (child_process.js:634:13)
at copyPrebuiltCompilers (C:\Users\reasonreact-todo\node_modules\bs-platform\scripts\install.js:284:6)
at Object. (C:\Users\reasonreact-todo\node_modules\bs-platform\scripts\install.js:377:3)
at Module._compile (internal/modules/cjs/loader.js:701:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:712:10)
at Module.load (internal/modules/cjs/loader.js:600:32)
at tryModuleLoad (internal/modules/cjs/loader.js:539:12)
at Function.Module._load (internal/modules/cjs/loader.js:531:3)
at Function.Module.runMain (internal/modules/cjs/loader.js:754:12)


It seems the instatllation failed at a copy operation which really should not happen. Can you just run the failed command by hand


Tried that command. There is no scripts folder under node_modules/bs-platform. Is there supposed to be one?


Note I am trying to install bs-platform globally, i.e. npm install -g bs-platform


I have /usr/local/lib/node_modules/bs-platform/scripts, bs-platform version 5.0.4 though.


I am on windows. When I install it globally on windows, it doesn’t seem to have scripts folder.


can you provide more context, or can you file an issue on github so that I can track it more regularly